Обучающие материалы | Nwicode CMS

Требования к серверу


Требования к программному обеспечению:

  • Поддерживаемая ОС: Linux (Centos 7 или более новая, Debian 9 или новее, Ubuntu 10.04 или новее).
  • Поддерживаемый сервер: Apache 2 или новее
  •  PHP 7.0
  • MySQL 5.5 или новее
  • Расширения PHP: GD, PDO MySQL, Simplexml, Curl, DOM, ioncube, mbstring, mod_rewrite
  • Функции PHP: exec (), allow url_fopen
  • Zip
  • Unzip
  • Минимальный OpenSSL 1.0.1
  • php-sqlite3 или glibc> = 2.12
  • Обязательно: необходимо получить панель управления с вашим сервером, например панель ISPmanager, cPanel или Parallel Plesk.
  • Для генератора apk:
    • — Установите эти 32-битные библиотеки, если они еще не установлены:
      -> Debian / Ubuntu:
      apt-get install lib32stdc ++ 6
      apt-get install lib32z1 lib32z1-dev
      -> CentOS / Fedora:
      yum -y install libstdc ++. I686 && yum — y install zlib.i686
    • Java 1.8+
    • Обычно мы рекомендуем VPS сервера

Требования к оборудованию:

Версия для одного приложения (START):

  • Выделенный сервер с процессором от 2vCore. 
  • Оперативная память: от 4 ГБ
  • Дисковое пространство: от 20 ГБ
  • Пропускная способность: от 100 МБ или от 1 ТБ пропускной способности в месяц.

Версия "Веб студия":

  • Тип сервера: виртуальный частный сервер (VPS) или выделенный сервер (без общих серверов)
  • SSH Root-доступ для технической поддержки
  • Процессор: от 2vCore
  • Оперативная память: от 4 ГБ
  • Дисковое пространство: от 20 ГБ
  • Пропускная способность: от 100 МБ или от 1 ТБ пропускной способности в месяц.

Версия "Бизнес Saas:

  • Тип сервера: Виртуальный частный сервер (VPS) или Выделенный сервер (без общих серверов).
  • SSH Root-доступ для технической поддержки
  • Процессор: от 2vCore
  • Оперативная память: от 4 ГБ
  • Дисковое пространство: от 20 ГБ
  • Пропускная способность: от 100 МБ или от 1 ТБ пропускной способности в месяц.

Рекомендуемые VPS для CMS NWICODE:

 Мы рекомендуем использовать VPS, предоставляемые нашим дата центром:

  • https://nwihost.com/  (выберите «ISPmanager» для дистрибутива, «Debian 9 64bit» )

Таким образом, ваш сервер будет полностью настроен и готов к размещению.


Перед тем как установить скрипт, произведите следующие настройки вашего сервера:

Внимание! —скрипт платформы работает только под управлением  Linux. » на сегодня самым проверенным и стабильным оказался Debian 9 64bit. для качественной работы приложения рекомендуем: <4 CORE*<2MHz, <4Gb RAM, SSD <30Gb, 100Mb/s, <PHP 7, cURL, MySQL, Java

С правами root  подключамся к SSH консоли.
apt-get update
—ставим CURL : apt-get install curl
—ставим на сервер JAVA для копиляции кодов: apt-get install openjdk-8-jdk openjdk-8-jre
для правильной работы компилятора, необходимы следующие пакеты: apt-get install lib32stdc++6 , apt-get install lib32z1 lib32z1-dev
для оптимизации картинок ставим 3 пакета: apt-get install pngquant, apt-get install jpegoptim, apt-get install optipng


Вернуться

Есть вопросы — спрашивайте!

Наши специалисты помогут Вам и окажут бесплатную консультацию

Документация

Новости 1 - 20 из 52
Начало | Пред. | 1 2 3 | След. | Конец